summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '3rdParty/GoogleTest/src/CMakeLists.txt')
-rw-r--r--3rdParty/GoogleTest/src/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/3rdParty/GoogleTest/src/CMakeLists.txt b/3rdParty/GoogleTest/src/CMakeLists.txt
new file mode 100644
index 0000000..8d2b552
--- /dev/null
+++ b/3rdParty/GoogleTest/src/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 2.6.2)
+
+project( googletest-distribution )
+
+enable_testing()
+
+option(BUILD_GTEST "Builds the googletest subproject" OFF)
+
+#Note that googlemock target already builds googletest
+option(BUILD_GMOCK "Builds the googlemock subproject" ON)
+
+if(BUILD_GMOCK)
+ add_subdirectory( googlemock )
+elseif(BUILD_GTEST)
+ add_subdirectory( googletest )
+endif()