summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Markmann <tm@ayena.de>2016-12-15 14:49:30 (GMT)
committerTobias Markmann <tm@ayena.de>2016-12-15 14:49:46 (GMT)
commit6cd7bef6eb507f979d7c964769429ef46e3e5aa9 (patch)
tree322d5c80e7be477758a8e97ecd8a64fbb09836de /Swift/Packaging/Debian/debian/rules
parent864904bcd7931ff7453ecb1de72496e4e3cf9c96 (diff)
parent2efefdc5ae847f5d187762e474d75c61560cba19 (diff)
downloadswift-6cd7bef6eb507f979d7c964769429ef46e3e5aa9.zip
swift-6cd7bef6eb507f979d7c964769429ef46e3e5aa9.tar.bz2
Merge branch 'swift-3.x’
* swift-3.x: - Fix building Swift on 32-bit Linux distributions - Remove optional_fwd.hpp use; workaround for Boost Bug #12179 - Split COPYING.thirdparty in contributions/dependencies - Fixes for building packages on Debian Conflicts: BuildTools/SCons/SConstruct Sluift/Console.h Sluift/ITunesInterface.h Sluift/Terminal.h Swift/Packaging/Debian/debian/control.in Swift/QtUI/SConscript Swiften/Elements/Stanza.h Swiften/FileTransfer/FileTransferTransporter.h Swiften/FileTransfer/IBBReceiveSession.h Swiften/JID/JID.h Swiften/Network/BoostConnectionServer.h Swiften/Network/ConnectionServer.h Swiften/Parser/AttributeMap.h Test-Information: Builds on macOS 10.12.1 with clang trunk. Change-Id: I9f41ab199f227bc106721627ea994313c68e5cfe
Diffstat (limited to 'Swift/Packaging/Debian/debian/rules')
-rwxr-xr-xSwift/Packaging/Debian/debian/rules52
1 files changed, 13 insertions, 39 deletions
diff --git a/Swift/Packaging/Debian/debian/rules b/Swift/Packaging/Debian/debian/rules
index 2bdfe3b..87c551b 100755
--- a/Swift/Packaging/Debian/debian/rules
+++ b/Swift/Packaging/Debian/debian/rules
@@ -2,52 +2,26 @@
#export DH_VERBOSE=1
export PYTHONDONTWRITEBYTECODE=1
+export QT_SELECT=qt5
SCONS_FLAGS=V=1 qt5=1 optimize=1 debug=1 allow_warnings=1 swiften_dll=1 docbook_xsl=/usr/share/xml/docbook/stylesheet/docbook-xsl docbook_xml=/usr/share/xml/docbook/schema/dtd/4.5 linkflags="$(shell dpkg-buildflags --get LDFLAGS)" ccflags="$(shell dpkg-buildflags --get CPPFLAGS) $(shell dpkg-buildflags --get CFLAGS)"
+SCONS_INSTALL_BASE=$(CURDIR)/debian/tmp
+SCONS_INSTALL_FLAGS=SWIFT_INSTALLDIR=$(SCONS_INSTALL_BASE)/usr SWIFTEN_INSTALLDIR=$(SCONS_INSTALL_BASE)/usr
+SWIFT_INSTALLDIR=$(SCONS_INSTALL_BASE)/usr SWIFTEN_INSTALLDIR=$(SCONS_INSTALL_BASE)/usr
-clean:
- dh_testdir
+%:
+ dh $@
+
+override_dh_clean:
dh_clean
- scons $(SCONS_FLAGS) $(SCONS_EXTRA_FLAGS) SWIFT_INSTALLDIR=$(CURDIR)/debian/tmp/usr SWIFTEN_INSTALLDIR=$(CURDIR)/debian/tmp/usr -c
+ scons $(SCONS_FLAGS) $(SCONS_EXTRA_FLAGS) $(SCONS_INSTALL_FLAGS) -c
-rm -rf .scon*
-rm -rf config.log
-configure:
+override_dh_configure:
-build: configure
- dh_testdir
+override_dh_auto_build:
scons $(SCONS_FLAGS) $(SCONS_EXTRA_FLAGS) Swift Swiften
-install: build
- dh_testroot
- dh_prep
- dh_installdirs
- scons $(SCONS_FLAGS) $(SCONS_EXTRA_FLAGS) SWIFT_INSTALLDIR=$(CURDIR)/debian/tmp/usr SWIFTEN_INSTALLDIR=$(CURDIR)/debian/tmp/usr $(CURDIR)/debian/tmp
- mkdir -p $(CURDIR)/debian/tmp/usr/share/lintian/overrides
- cp debian/binary-overrides/* $(CURDIR)/debian/tmp/usr/share/lintian/overrides/
-
-binary-indep: install
-binary-arch: install
- dh_testdir
- dh_testroot
- dh_install --sourcedir=debian/tmp
- dh_installchangelogs
- dh_installdocs
- dh_installmenu
- dh_installman -a
- dh_link
- dh_strip --dbg-package=swift-im-dbg
- dh_compress
- dh_fixperms
- dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-
-build-arch: build
-build-indep: build
-.PHONY: build clean binary-indep binary-arch binary install configure build-arch build-indep
+override_dh_auto_install:
+ scons $(SCONS_FLAGS) $(SCONS_EXTRA_FLAGS) $(SCONS_INSTALL_FLAGS) $(SCONS_INSTALL_BASE)