summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemko Tronçon <git@el-tramo.be>2009-06-16 19:57:48 (GMT)
committerRemko Tronçon <git@el-tramo.be>2009-06-16 19:57:48 (GMT)
commita2e0cf9108081663607706f661f411a5fcf86e1d (patch)
tree65f2a01f8d91c6d8a87f4720512534caa2430010 /configure.in
parent9bc8ddaf40d73647944592385bf56ece41046846 (diff)
downloadswift-a2e0cf9108081663607706f661f411a5fcf86e1d.zip
swift-a2e0cf9108081663607706f661f411a5fcf86e1d.tar.bz2
Make Swift compilation optional.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index f703be9..41ef7a7 100644
--- a/configure.in
+++ b/configure.in
@@ -46,6 +46,8 @@ case $host in
CONFIG_LIBS="$CONFIG_LIBS -lstdc++"
esac
+AC_CHECK_FILE([Swift/Makefile.inc], [BUILD_SWIFT="yes"], [BUILD_SWIFT="no"])
+
################################################################################
# Configure options
################################################################################
@@ -127,9 +129,11 @@ if test -z "$MM"; then
fi
# Qt
-AX_QT()
-if test "$HAVE_QT" != yes; then
- AC_MSG_ERROR([Could not find Qt])
+if test "$BUILD_SWIFT" == "yes"; then
+ AX_QT()
+ if test "$HAVE_QT" != yes; then
+ AC_MSG_ERROR([Could not find Qt])
+ fi
fi
# Expat
@@ -206,6 +210,7 @@ AC_SUBST(CONFIG_HAVE_OPENSSL)
AC_SUBST(USE_BUNDLED_EXPAT)
AC_SUBST(CONFIG_HAVE_LIBXML)
AC_SUBST(QMAKE)
+AC_SUBST(BUILD_SWIFT)
AC_CONFIG_FILES([Makefile.config])
AC_OUTPUT